hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon (JIRA)" <j...@apache.org>
Subject [jira] Created: (HAMA-67) Consider refactoring the overall design
Date Sat, 20 Sep 2008 17:11:44 GMT
Consider refactoring the overall design 

                 Key: HAMA-67
                 URL: https://issues.apache.org/jira/browse/HAMA-67
             Project: Hama
          Issue Type: Improvement
          Components: implementation
            Reporter: Edward J. Yoon
            Assignee: Edward J. Yoon
             Fix For: 0.1.0

- Map datum shoulde be <IntWritable, VectorWritable>.
- VectorWritable should returns Vector object.
- Vector interface, AbstractVector, DenseVector seems appropriate.
- DenseMatrix and DenseVector operation methods should returns DenseMatrix and DenseVector.
- Matrix type should be declared by constructor.
- AbstractMatrix.execute() method should be moved to the utility class.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message