hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon" <edwardy...@apache.org>
Subject Re: Discussion of refactoring AbstractBase
Date Thu, 21 Aug 2008 10:51:04 GMT
Yes, I agree with you. It should be NumberUtil as a hbase.util.Bytes.
I'll create issue.

-Ed

On Thu, Aug 21, 2008 at 8:00 AM, Chanwit Kaewkasi <chanwit@gmail.com> wrote:
> Hello,
>
> AbstractBase seems to be totally a helper, rather than a base class.
> It's just for providing utility methods to use in a matrix.
> I propose to get rid of it and change it to be a helper, with static methods.
> Then we can use "import static" (a Java 5 feature) to import all
> static methods, and use them in the same way as the current
> implementation.
>
> Because AbstractBase has no state, and all of its methods has no
> side-effect, so it is not necessary to be in the class hierarchy.
>
> Regards,
>
> Chanwit
>



-- 
Best regards, Edward J. Yoon
edwardyoon@apache.org
http://blog.udanax.org

Mime
View raw message