hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "joosun yoon" <ologi...@gmail.com>
Subject Re: Discussion of refactoring AbstractBase
Date Thu, 21 Aug 2008 13:32:09 GMT
Let's use utility&helper classes naming as "Utils" suffix, and How should
util classes with static methods be constructor private?

2008/8/21 Edward J. Yoon <edwardyoon@apache.org>

> Yes, I agree with you. It should be NumberUtil as a hbase.util.Bytes.
> I'll create issue.
>
> -Ed
>
> On Thu, Aug 21, 2008 at 8:00 AM, Chanwit Kaewkasi <chanwit@gmail.com>
> wrote:
> > Hello,
> >
> > AbstractBase seems to be totally a helper, rather than a base class.
> > It's just for providing utility methods to use in a matrix.
> > I propose to get rid of it and change it to be a helper, with static
> methods.
> > Then we can use "import static" (a Java 5 feature) to import all
> > static methods, and use them in the same way as the current
> > implementation.
> >
> > Because AbstractBase has no state, and all of its methods has no
> > side-effect, so it is not necessary to be in the class hierarchy.
> >
> > Regards,
> >
> > Chanwit
> >
>
>
>
>
> --
> Best regards, Edward J. Yoon
> edwardyoon@apache.org
> http://blog.udanax.org
>



-- 
Yoon Joo Sun
Java Developer Engineer
Blog - http://www.ologist.co.kr

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message