hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Xu <mx2...@gmail.com>
Subject Re: Strage issue with chroot
Date Mon, 30 Aug 2010 13:39:22 GMT
it is not. 

you could try connecting to zk first and creating the chroot yourselves
before using it.

michael


On Tue, 2010-08-31 at 01:29 +1200, Todd Nine wrote:
> Hi all,
>   I'm running into a very strange issue with using chroot.  I've defined the
> following URL in my java client.
> 
> zookeeper.connections=localhost:2181/com/spidertracks/aviator
> 
> When I run my unit tests against Zookeeper, all works as expected when I
> create the path "/cluster/election/node_xx" for leader election.  However,
> when I create the parent path of "/cluster/election" in my integration
> tests, I receive this error.
> 
> INFO [runningservices-SendThread(localhost:2181)] - Session establishment
> complete on server localhost/fe80:0:0:0:0:0:0:1%1:2181, sessionid =
> 0x12ac326df770000, negotiated timeout = 50000
>  INFO [ProcessThread:-1] - Got user-level KeeperException when processing
> sessionid:0x12ac326df770000 type:create cxid:0x5 zxid:0xfffffffffffffffe
> txntype:unknown reqpath:n/a Error Path:/com/spidertracks/aviator
> Error:KeeperErrorCode = NoNode for /com/spidertracks/aviator
> 
> 
> Is the path specified in chroot not created automatically when I make an api
> call such as zooKeeper.create("/cluster/election", false)?
> 
> Thanks,
> Todd



Mime
View raw message