hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Reed <br...@yahoo-inc.com>
Subject Re: running the systest
Date Fri, 09 Jul 2010 19:11:49 GMT
can you try the following:

Index: src/contrib/fatjar/build.xml
===================================================================
--- src/contrib/fatjar/build.xml        (revision 962637)
+++ src/contrib/fatjar/build.xml        (working copy)
@@ -46,6 +46,7 @@
<fileset dir="${zk.root}/build/classes" excludes="**/.generated"/>
<fileset dir="${zk.root}/build/test/classes"/>
<zipgroupfileset dir="${zk.root}/build/lib" includes="*.jar" />
+ <zipgroupfileset dir="${zk.root}/build/test/lib" includes="*.jar" />
<zipgroupfileset dir="${zk.root}/src/java/lib" includes="*.jar" />
</jar>
</target>


thanx
ben

On 07/09/2010 09:04 AM, Stuart Halloway wrote:
> Happy to do it. Should I change the fatjar build to add junit, or is there another way
folks prefer to do it?
>
> I am assuming that somebody is running the tests and has a local workaround in place.
:-)
>
> Stu
>
>    
>> Hi Stuart,
>> The instructions are just out of date. If you could open a jira and post a
>> patch to it that would be great!
>>
>> We should try getting this in 3.3.2! That would be useful!
>>
>> Thanks
>> mahadev
>>
>>
>> On 7/9/10 6:36 AM, "Stuart Halloway"<stuart.halloway@gmail.com>  wrote:
>>
>>      
>>> Hi all,
>>>
>>> I am trying to run the systest and have hit a few minor issues:
>>>
>>> (1) The readme says src/contrib/jarjar, apparently should be
>>> src/contrib/fatjar
>>>
>>> (2) The compiled fatjar seems to be missing junit, so the launch instructions
>>> do not work.
>>>
>>> I can fix or workaround these, but I wanted to see if maybe the instructions
>>> are just out of date, and there is an easy (but currently undocumented) way to
>>> launch the tests.
>>>
>>> Thanks,
>>> Stu
>>>
>>>        
>>      
>    


Mime
View raw message