hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Test <erik.shi...@gmail.com>
Subject Re: 答复: Starting zookeeper in replicated mode
Date Tue, 22 Jun 2010 13:17:33 GMT
Thanks for your help. The missing file issue is resolved.

I was confused by how to start zookeeper because a firewall is blocking
connections between nodes. The odd thing is hadoop can run on its own with
the configured iptables but doesn't work with zookeeper for some reason. The
problem here is I can't turn off the firewall and need to configure the
firewall so that zookeeper can work correctly.

I'm going to work on the iptables to open connections needed by zookeeper.
If any one knows of a way to do this or even just a link to configuring an
iptable with zookeeper in mind, I'd appreciate it.

Thanks again for the help.
Erik


On 21 June 2010 20:56, Joe Zou <joez@hz.webex.com> wrote:

> Hi:
> You miss the file.
> the Caused by: java.lang.IllegalArgumentException: /var/zookeeper/myid file
> is missing
>        at
> thanks
> Joe Zou
> -----邮件原件-----
> 发件人: Erik Test [mailto:erik.shiken@gmail.com]
> 发送时间: Tuesday, June 22, 2010 3:05 AM
> 收件人: zookeeper-user@hadoop.apache.org
> 主题: Starting zookeeper in replicated mode
>
> Hi All,
>
> I'm having a problem with installing zookeeper on a cluster with 6 nodes in
> replicated mode. I was able to install and run zookeeper in standalone mode
> but I'm unable to run zookeeper in replicated mode.
>
> I've added a list of servers in zoo.cfg as suggested by the ZooKeeper
> Getting Started Guide but I get these logs displayed to screen:
>
> *[root@master1 bin]# ./zkServer.sh start
> JMX enabled by default
> Using config: /root/zookeeper-3.2.2/bin/../conf/zoo.cfg
> Starting zookeeper ...
> STARTED
> [root@master1 bin]# 2010-06-21 12:25:23,738 - INFO
> [main:QuorumPeerConfig@80] - Reading configuration from:
> /root/zookeeper-3.2.2/bin/../conf/zoo.cfg
> 2010-06-21 12:25:23,743 - INFO  [main:QuorumPeerConfig@232] - Defaulting
> to
> majority quorums
> 2010-06-21 12:25:23,745 - FATAL [main:QuorumPeerMain@82] - Invalid config,
> exiting abnormally
> org.apache.zookeeper.server.quorum.QuorumPeerConfig$ConfigException: Error
> processing /root/zookeeper-3.2.2/bin/../conf/zoo.cfg
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.java:100)
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:98)
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:75)
> Caused by: java.lang.IllegalArgumentException: /var/zookeeper/myid file is
> missing
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerConfig.parseProperties(QuorumPeerConfig.java:238)
>        at
>
> org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.java:96)
>        ... 2 more
> Invalid config, exiting abnormally*
>
> And here is my config file:
> *
> # The number of milliseconds of each tick
> tickTime=2000
> # The number of ticks that the initial
> # synchronization phase can take
> initLimit=5
> # The number of ticks that can pass between
> # sending a request and getting an acknowledgement
> syncLimit=2
> # the directory where the snapshot is stored.
> dataDir=/var/zookeeper
> # the port at which the clients will connect
> clientPort=2181
> server.1=master1:2888:3888
> server.2=slave2:2888:3888
> server.3=slave3:2888:3888
> *
> I'm a little confused as to why this doesn't work and I haven't had any
> luck
> finding answers to some questions I have.
>
> Am I supposed to have an instance of ZooKeeper on each node started before
> running in replication mode? Should I have each node that will be running
> ZK
> listed in the config file? Should I be using an IP address to point to a
> server instead of a hostname?
>
> Thanks for your time.
> Erik
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message