hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jordan Zimmerman <jzimmer...@proofpoint.com>
Subject Re: Xid out of order. Got 8 expected 7
Date Wed, 12 May 2010 18:52:44 GMT
So, I'm off the Jira hook then?

-JZ

On May 12, 2010, at 11:49 AM, Patrick Hunt wrote:

> You're right. Ben, would you mind entering a JIRA?
> 
> Patrick
> 
> On 05/12/2010 11:41 AM, Benjamin Reed wrote:
>> is this a bug? shouldn't we be returning an error.
>> 
>> ben
>> 
>> On 05/12/2010 11:34 AM, Patrick Hunt wrote:
>>> I think that explains it then - the server is probably dropping the new
>>> (3.3.0) "getChildren" message (xid 7) as it (3.2.2 server) doesn't know
>>> about that message type. Then the server responds to the client for a
>>> subsequent operation (xid 8), and at that point the client notices that
>>> getChildren (xid 7) got lost.
>>> 
>>> Patrick
>>> 
>>> On 05/12/2010 11:30 AM, Jordan Zimmerman wrote:
>>>> Oh, OK. When I get a moment I'll restart the 3.2.2 and post logs,
>>>> etc.
>>>> 
>>>> Yes, we're calling getChildren with the callback.
>>>> 
>>>> -JZ
>>>> 
>>>> On May 12, 2010, at 11:28 AM, Patrick Hunt wrote:
>>>> 
>>>>> I'm still interested though... Are you using the new "getChildren"
>>>>> api that was added to the client in 3.3.0? (it provides a Stat
>>>>> object on return, the old getChildren did not). While we don't
>>>>> officially support 3.3.0 client with 3.2.2 server (we do support
>>>>> the other way around), there shouldn't be they type of problem with
>>>>> this configuration as you describe. I'd still be interested for you
>>>>> to create that jira.
>>>>> 
>>>>> Regards,
>>>>> 
>>>>> Patrick
>>>>> 
>>>>> On 05/12/2010 11:23 AM, Jordan Zimmerman wrote:
>>>>>> Apologies...
>>>>>> 
>>>>>> I thought I was running 3.3.0 server, but was running 3.2.2
>>>>>> server with 3.3.0 client. I upgraded the server and now all works
>>>>>> again. Sorry to trouble y'all.
>>>>>> 
>>>>>> -Jordan
>>>>>> 
>>>>>> On May 12, 2010, at 11:11 AM, Patrick Hunt wrote:
>>>>>> 
>>>>>>> Hi Jordan, you've seen this once or frequently? (having the
>>>>>>> server + client logs will help alot)
>>>>>>> 
>>>>>>> Patrick
>>>>>>> 
>>>>>>> On 05/12/2010 11:08 AM, Jordan Zimmerman wrote:
>>>>>>>> Sure - if you think it's a bug.
>>>>>>>> 
>>>>>>>> We were using Zookeeper without issue. I then refactored
a
>>>>>>>> bunch of code and this new behavior started. I'm starting
ZK
>>>>>>>> using "zkServer start" and haven't made any changes to the
>>>>>>>> code at all.
>>>>>>>> 
>>>>>>>> I'll get the logs together and post a JIRA.
>>>>>>>> 
>>>>>>>> -JZ
>>>>>>>> 
>>>>>>>> On May 12, 2010, at 10:59 AM, Mahadev Konar wrote:
>>>>>>>> 
>>>>>>>>> Hi Jordan, Can you create a jira for this? And attach
all
>>>>>>>>> the server logs and client logs related to this timeline?
>>>>>>>>> How did you start up the servers? Is there some changes
you
>>>>>>>>> might have made accidentatlly to the servers?
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> Thanks mahadev
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> On 5/12/10 10:49 AM, "Jordan
>>>>>>>>> Zimmerman"<jzimmerman@proofpoint.com> wrote:
>>>>>>>>> 
>>>>>>>>>> We've just started seeing an odd error and are having
>>>>>>>>>> trouble determining the cause. "Xid out of order.
Got 8
>>>>>>>>>> expected 7" Any hints on what can cause this? Any
ideas
>>>>>>>>>> on how to debug?
>>>>>>>>>> 
>>>>>>>>>> We're using ZK 3.3.0. The error occurs in
>>>>>>>>>> ClientCnxn.java line 781
>>>>>>>>>> 
>>>>>>>>>> -Jordan
>> 


Mime
View raw message