hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: Xid out of order. Got 8 expected 7
Date Wed, 12 May 2010 18:28:21 GMT
I'm still interested though... Are you using the new "getChildren" api 
that was added to the client in 3.3.0? (it provides a Stat object on 
return, the old getChildren did not). While we don't officially support 
3.3.0 client with 3.2.2 server (we do support the other way around), 
there shouldn't be they type of problem with this configuration as you 
describe. I'd still be interested for you to create that jira.

Regards,

Patrick

On 05/12/2010 11:23 AM, Jordan Zimmerman wrote:
> Apologies...
>
> I thought I was running 3.3.0 server, but was running 3.2.2 server
> with 3.3.0 client. I upgraded the server and now all works again.
> Sorry to trouble y'all.
>
> -Jordan
>
> On May 12, 2010, at 11:11 AM, Patrick Hunt wrote:
>
>> Hi Jordan, you've seen this once or frequently? (having the server
>> + client logs will help alot)
>>
>> Patrick
>>
>> On 05/12/2010 11:08 AM, Jordan Zimmerman wrote:
>>> Sure - if you think it's a bug.
>>>
>>> We were using Zookeeper without issue. I then refactored a bunch
>>> of code and this new behavior started. I'm starting ZK using
>>> "zkServer start" and haven't made any changes to the code at
>>> all.
>>>
>>> I'll get the logs together and post a JIRA.
>>>
>>> -JZ
>>>
>>> On May 12, 2010, at 10:59 AM, Mahadev Konar wrote:
>>>
>>>> Hi Jordan, Can you create a jira for this? And attach all the
>>>> server logs and client logs related to this timeline? How did
>>>> you start up the servers? Is there some changes you might have
>>>> made accidentatlly to the servers?
>>>>
>>>>
>>>> Thanks mahadev
>>>>
>>>>
>>>> On 5/12/10 10:49 AM, "Jordan
>>>> Zimmerman"<jzimmerman@proofpoint.com> wrote:
>>>>
>>>>> We've just started seeing an odd error and are having
>>>>> trouble determining the cause. "Xid out of order. Got 8
>>>>> expected 7" Any hints on what can cause this? Any ideas on
>>>>> how to debug?
>>>>>
>>>>> We're using ZK 3.3.0. The error occurs in ClientCnxn.java
>>>>> line 781
>>>>>
>>>>> -Jordan
>>>>
>>>
>

Mime
View raw message