hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry Robinson <he...@cloudera.com>
Subject Re: Starting Zookeeper on Amazon EC2
Date Wed, 09 Dec 2009 18:09:18 GMT
The 3.2.1 command line is a lot nicer (has an actual prompt, tab
auto-completion, shows your connection status etc) - if you can upgrade to
3.2.1 which is a good deal more modern, I would recommend it. If I recall
correctly, there was no prompt in 3.1.1...

Henry

On Wed, Dec 9, 2009 at 9:36 AM, Something Something <
mailinglists19@gmail.com> wrote:

> Without -server made some progress, but don't see a command prompt.
> Shouldn't I see one?
>
> This is what I see:
> 2009-12-09 17:27:56,709 - INFO  [main:ZooKeeper@341] - Initiating client
> connection, host=127.0.0.1:2181 sessionTimeout=5000
> watcher=org.apache.zookeeper.ZooKeeperMain$MyWatcher@32fb4f
> 2009-12-09 17:27:56,710 - INFO  [main:ClientCnxn@91] -
> zookeeper.disableAutoWatchReset is false
> 2009-12-09 17:27:56,792 - INFO  [main-SendThread:ClientCnxn$SendThread@800
> ]
> - Attempting connection to server /127.0.0.1:2181
> 2009-12-09 17:27:56,802 - INFO  [main-SendThread:ClientCnxn$SendThread@716
> ]
> - Priming connection to java.nio.channels.SocketChannel[connected local=/
> 127.0.0.1:49619 remote=/127.0.0.1:2181]
> 2009-12-09 17:27:56,806 - INFO  [main-SendThread:ClientCnxn$SendThread@868
> ]
> - Server connection successful
> WatchedEvent: Server state change. New state: SyncConnected
>
>
> Should I just use 3.2.1 version?
>
>
>
> On Wed, Dec 9, 2009 at 9:20 AM, Mahadev Konar <mahadev@yahoo-inc.com>
> wrote:
>
> > Hi,
> >  Can you try this?
> >
> > bin/zkCli.sh 127.0.0.1:2181
> >
> > The -server command was added later as far as I remember.
> >
> > Thanks
> > mahadev
> >
> >
> >
> > On 12/9/09 9:05 AM, "Something Something" <mailinglists19@gmail.com>
> > wrote:
> >
> > > I am trying to start ZooKeeper on an EC2 instance.  Here's what I did:
> > >
> > > 1)  Downloaded & Unpacked ZooKeeper 3.1.1 on EC2 instance.
> > > 2)  cp /conf/zoo_sample.cfg /conf/zoo.cfg
> > > 3)  Changed the dataDir path to point to my EBS volume.
> > > 4)  In one command window, ran /bin/zkServer.sh start
> > > (The last message I see is... "Snapshotting: 0)
> > >
> > > 5)  Opened another command window, and ran jps
> > > (This shows a new process called, QuorumPeerMain.  That's the only one
> I
> > > see.)
> > >
> > > 6)  As per documentation, tried
> > >
> > > bin/zkCli.sh -server 127.0.0.1:2181
> > >
> > > (This gives me IOException: USAGE)
> > >
> > > 7) So I ran:
> > >
> > > bin/zkCli.sh -server 127.0.0.1:2181 ls
> > >
> > > Got UnknownHostException: -server
> > >
> > > 8)  So I tried various ways of specifying IP address in EC2, such as:
> > >
> > > 10.xx.xx.xx
> > > ec2-xx-xx-xx-xxx.compute-1.amazonaws.com
> > > domU-12-31-xx-xx-xx-xx.compute-1.internal
> > > domU-12-31-xx-xx-xx-xx
> > >
> > > None of them worked.  Keep getting UnknownHostException.
> > >
> > > What am I doing wrong.  Please help.  Thanks.
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message