hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: Failure to Launch
Date Wed, 02 Dec 2009 07:40:17 GMT
Hi Alan, turns out there were a number of issues with the scripts on
cygwin, see the patch attached to the JIRA that will be applied to 3.3.0.

https://issues.apache.org/jira/browse/ZOOKEEPER-606

See the tar attached to this email, give these scripts a try (replace
your entire bin directory with contents of this archive)

Patrick

Ratner, Alan S (IS) wrote:
> I have been unsuccessful at getting zookeeper to run on top of Cygwin.
> The dialog has been:
> 
> $ bin/zkServer.sh start
> JMX enabled by default
> Using config: /cygdrive/c/zookeeper-3.2.1/bin/../conf/zoo.cfg
> Starting zookeeper ...
> STARTED
> 
> Exception in thread "main" java.lang.NoClassDefFoundError: {list of jar
> files such as
> /cygdrive/c/zookeeper-3/2/1/bin////src/java/lib/xerces-1/4/4/jar => all
> dots were replaced with slashes}
> Caused by: java.lang.ClassNotFoundException: {list of jar files such as
> .cygdrive.c.zookeeper-3.2.1.bin....src.java.lib.xerces-1.4.4.jar => all
> slashes were replaced with dots}
> At java.net.URLClassLoader$1.run(Unknown Source)
> ...
> At java.lang.ClassLoader.loadClassInternal(Unknown Source)
> Could not find the main class: {list of jar files such as
> /cygdrive/c/zookeeper-3.2.1/bin/../src/java/lib/xerces-1.4.4.jar =>
> correct location of files }
> Program will exit.
> 
> Does anyone have any ideas on what else I can try?
> 
> Alan
> 
> 
> 
> 
> 


Mime
View raw message