hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Something Something <mailinglist...@gmail.com>
Subject Starting Zookeeper on Amazon EC2
Date Wed, 09 Dec 2009 17:05:21 GMT
I am trying to start ZooKeeper on an EC2 instance.  Here's what I did:

1)  Downloaded & Unpacked ZooKeeper 3.1.1 on EC2 instance.
2)  cp /conf/zoo_sample.cfg /conf/zoo.cfg
3)  Changed the dataDir path to point to my EBS volume.
4)  In one command window, ran /bin/zkServer.sh start
(The last message I see is... "Snapshotting: 0)

5)  Opened another command window, and ran jps
(This shows a new process called, QuorumPeerMain.  That's the only one I
see.)

6)  As per documentation, tried

bin/zkCli.sh -server 127.0.0.1:2181

(This gives me IOException: USAGE)

7) So I ran:

bin/zkCli.sh -server 127.0.0.1:2181 ls

Got UnknownHostException: -server

8)  So I tried various ways of specifying IP address in EC2, such as:

10.xx.xx.xx
ec2-xx-xx-xx-xxx.compute-1.amazonaws.com
domU-12-31-xx-xx-xx-xx.compute-1.internal
domU-12-31-xx-xx-xx-xx

None of them worked.  Keep getting UnknownHostException.

What am I doing wrong.  Please help.  Thanks.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message