hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry Robinson <he...@cloudera.com>
Subject Re: Cluster Configuration Issues
Date Thu, 22 Oct 2009 22:00:37 GMT
yeah - thought this was it: you've missed the forward slash on
home/mark/zookeeper (this turned up on your exception message).

On Thu, Oct 22, 2009 at 2:55 PM, Mark Vigeant
<mark.vigeant@riskmetrics.com>wrote:

> Yeah I just figured out the problem with zoocfg.py
>
> I am running as the same user who created myid. Here's my config:
>
> zoo.cfg
>
> tickTime-2000
> dataDir=home/mark/zookeeper
> clientPort=2181
> initLimit=5
> syncLimit=2
> server.1= hermes:2888:3888
> server.2= leela:2888:3888
>
> on the machines hermes and leela I've put myid files in
> /home/mark/zookeeper
> with the numbers 1 and 2 respectively
> -----Original Message-----
> From: Henry Robinson [mailto:henry@cloudera.com]
> Sent: Thursday, October 22, 2009 5:43 PM
> To: zookeeper-user@hadoop.apache.org
> Subject: Re: Cluster Configuration Issues
>
> Hi Mark -
>
> The Python error relates to not being able to find the zoocfg module - is
> zoocfg.py in the same directory as zkconf.py?
>
> Another couple of questions - are you running zookeeper as the same user
> who
> created myid? Can you post your entire configuration file please - copy and
> paste?
>
> Henry
>
> On Thu, Oct 22, 2009 at 2:32 PM, Mark Vigeant
> <mark.vigeant@riskmetrics.com>wrote:
>
> > Before I make the Jira, I am trying to go with Ted's advice to use the
> > python script.
> >
> > Unfortunately I'm relatively unfamiliar with python so I'm having trouble
> > running it.
> >
> > When I execute "Python zkconf.py" on the command line it tells me:
> > Traceback (most recent call last):
> >   File "zkconf.py", line 27, in <module>
> >        from zoocfg import zoocfg
> > ImportError: No module named zoocfg
> >
> > The same error comes when I try to call zkcfg.py from the python
> interface
> > and when I try running
> > Python zkconf.py -help /home/hadoop/zookeeper-3.2.1/ /home/hadoop (as I
> > gathered from the Usage). Any suggestions?
> >
> > Also, I've been using zookeeper 3.2.1
> > -----Original Message-----
> > From: Ted Dunning [mailto:ted.dunning@gmail.com]
> > Sent: Thursday, October 22, 2009 4:33 PM
> > To: zookeeper-user@hadoop.apache.org
> > Subject: Re: Cluster Configuration Issues
> >
> > Try Patrick's utility for creating the config files and compare the
> result
> > to your hand-made files.
> >
> > On Thu, Oct 22, 2009 at 1:04 PM, Mark Vigeant
> > <mark.vigeant@riskmetrics.com>wrote:
> >
> > > The file contains the number 1 and nothing else. My other node has the
> > > number 2 (I only have 2 machines right now, I know it makes more sense
> to
> > > run an odd number of zookeeper nodes but I just want to make sure it
> > works
> > > first). Any suggestions?
> > >
> >
> >
> >
> > --
> > Ted Dunning, CTO
> > DeepDyve
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message