hadoop-zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: c client error message with chroot
Date Mon, 03 Aug 2009 16:32:21 GMT
Please do enter a JIRA. Looking at the source it seems that we log and 
error, but the calling code continues. I think this is happening because 
the chroot c lib code is not handling znode watches separate from state 
change notifications.

The calling code just continues after logging an (invalid I think) error 
- can you try it out and see if it works, even though the error message 
is being displayed (with chroot I mean).

Thanks.

Patrick

Mahadev Konar wrote:
> This looks like a bug. Does this happen without doing any reads/writes using
> the zookeeper handle?
> 
> Please do open a jira for this.
> 
> 
> Thanks
> mahadev
> 
> 
> On 8/2/09 10:53 PM, "Michi Mutsuzaki" <michi@cs.stanford.edu> wrote:
> 
>> Hello,
>>
>> I'm doing something like this (using zookeeper-3.2.0):
>>
>> zhandle_t* zh = zookeeper_init("localhost:2818/servers", watcher,
>> 1000, 0, 0, 0);
>>
>> and getting this error:
>>
>> 2009-08-03 05:48:30,693:3380(0x40a04950):ZOO_INFO@check_events@1439:
>> initiated connection to server [127.0.0.1:2181]
>> 2009-08-03 05:48:30,705:3380(0x40a04950):ZOO_INFO@check_events@1484:
>> connected to server [127.0.0.1:2181] with session id=122ddb9be64016d
>> 2009-08-03 05:48:30,705:3380(0x40c05950):ZOO_ERROR@sub_string@730:
>> server path  does not include chroot path /servers
>>
>> The error log doesn't appear if I use "localhost:2818" without chroot.
>> Is this actually an error?
>>
>> Thanks!
>> --Michi
> 

Mime
View raw message