hadoop-zookeeper-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kapil Thangavelu (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (ZOOKEEPER-777) setting acl on a non existant node should return no node error
Date Tue, 01 Jun 2010 13:55:44 GMT

     [ https://issues.apache.org/jira/browse/ZOOKEEPER-777?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kapil Thangavelu resolved ZOOKEEPER-777.
----------------------------------------

    Resolution: Fixed

i think the problem was in a the client library on top of zookeeper, i tried debugging the
server code but its doing everything correct  and raising the exception and no node error
code. the python script savu attached works as expected, i'm closing this out as invalid.

> setting acl on a non existant node should return no node error
> --------------------------------------------------------------
>
>                 Key: ZOOKEEPER-777
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-777
>             Project: Zookeeper
>          Issue Type: Bug
>          Components: server
>    Affects Versions: 3.3.0, 3.3.1
>            Reporter: Kapil Thangavelu
>             Fix For: 3.4.0
>
>         Attachments: test.py
>
>
> currently it just returns successfully, but the acl can't be retrieved, and if any value
is being stored, its overwritten when the node is created.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message