hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szilard Nemeth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-9052) Replace all MockRM submit method definitions with a builder
Date Thu, 11 Apr 2019 15:03:00 GMT

     [ https://issues.apache.org/jira/browse/YARN-9052?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Szilard Nemeth updated YARN-9052:
---------------------------------
    Attachment: YARN-9052.003.patch

> Replace all MockRM submit method definitions with a builder
> -----------------------------------------------------------
>
>                 Key: YARN-9052
>                 URL: https://issues.apache.org/jira/browse/YARN-9052
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Szilard Nemeth
>            Assignee: Szilard Nemeth
>            Priority: Minor
>         Attachments: YARN-9052.001.patch, YARN-9052.002.patch, YARN-9052.003.patch
>
>
> MockRM has 31 definitions of submitApp, most of them having more than acceptable number
of parameters, ranging from 2 to even 22 parameters, which makes the code completely unreadable.
> On top of unreadability, it's very hard to follow what RmApp will be produced for tests
as they often pass a lot of empty / null values as parameters.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message