hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haibo Chen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-8750) Refactor TestQueueMetrics
Date Wed, 03 Oct 2018 16:52:06 GMT

    [ https://issues.apache.org/jira/browse/YARN-8750?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16637190#comment-16637190

Haibo Chen commented on YARN-8750:

Thank [~snemeth] for the update. The *MetricsChecker is delta based, by which I mean we can
create one from another and just specify what values have changed as AppMetricsChecker.createFromChecker(appMetricsChecker).gaugeInt().gaugeLong().

I can see in  testSingleQueueWithUserMetrics() and  testTwoLevelWithUserMetrics(), the dependency
is messed up. We should create a AppMetricsChecker instance for queueSource and another instance
for parentQueueSource.

> Refactor TestQueueMetrics
> -------------------------
>                 Key: YARN-8750
>                 URL: https://issues.apache.org/jira/browse/YARN-8750
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>            Reporter: Szilard Nemeth
>            Assignee: Szilard Nemeth
>            Priority: Minor
>         Attachments: YARN-8750.001.patch, YARN-8750.002.patch, YARN-8750.003.patch, YARN-8750.004.patch,
> {{TestQueueMetrics#checkApps}} and {{TestQueueMetrics#checkResources}} have 8 and 14
parameters, respectively.
> It is very hard to read the testcases that are using these methods. 

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message