hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Lowe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-8284) get_docker_command refactoring
Date Tue, 15 May 2018 22:51:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-8284?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16476577#comment-16476577
] 

Jason Lowe commented on YARN-8284:
----------------------------------

Thanks for updating the patch!  +1 lgtm.  I'll commit this tomorrow if there are no objections.

> get_docker_command refactoring
> ------------------------------
>
>                 Key: YARN-8284
>                 URL: https://issues.apache.org/jira/browse/YARN-8284
>             Project: Hadoop YARN
>          Issue Type: Improvement
>    Affects Versions: 3.2.0, 3.1.1
>            Reporter: Jason Lowe
>            Assignee: Eric Badger
>            Priority: Minor
>         Attachments: YARN-8284.001.patch, YARN-8284.002.patch
>
>
> YARN-8274 occurred because get_docker_command's helper functions each have to remember
to put the docker binary as the first argument.  This is error prone and causes code duplication
for each of the helper functions.  It would be safer and simpler if get_docker_command initialized
the docker binary argument in one place and each of the helper functions only added the arguments
specific to their particular docker sub-command.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message