hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sunil G (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7892) Revisit NodeAttribute class structure
Date Sat, 05 May 2018 04:26:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7892?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16464619#comment-16464619
] 

Sunil G commented on YARN-7892:
-------------------------------

Thanks [~Naganarasimha] for the patch.

I had an offline discussion with [~leftnoteasy] on user facing api's and there are couple
of thoughts.
 # {{NodeAttributeIDProto}} could be renamed to {{NodeAttributeKeyProto}}
 # For below api, its better to remove the second map and convert the same to an object.

{code:java}
  public abstract Map<NodeAttributeID, Map<String, String>> getAttributesToNodes(
      Set<NodeAttributeID> attributes){code}
*Map<String, String>* to be changed an object which could be returned to user. This
will make apis more cleaner and easier to maintain.

> Revisit NodeAttribute class structure
> -------------------------------------
>
>                 Key: YARN-7892
>                 URL: https://issues.apache.org/jira/browse/YARN-7892
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Naganarasimha G R
>            Assignee: Naganarasimha G R
>            Priority: Major
>         Attachments: YARN-7892-YARN-3409.001.patch, YARN-7892-YARN-3409.002.patch, YARN-7892-YARN-3409.003.WIP.patch,
YARN-7892-YARN-3409.003.patch, YARN-7892-YARN-3409.004.patch, YARN-7892-YARN-3409.005.patch
>
>
> In the existing structure, we had kept the type and value along with the attribute which
would create confusion to the user to understand the APIs as they would not be clear as to
what needs to be sent for type and value while fetching the mappings for node(s).
> As well as equals will not make sense when we compare only for prefix and name where
as values for them might be different.  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message