hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gour Saha (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-8084) Yarn native service classes renaming for easier development?
Date Wed, 28 Mar 2018 19:23:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-8084?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16417965#comment-16417965
] 

Gour Saha commented on YARN-8084:
---------------------------------

For the service.component.Component I suggest to rename it to ComponentManager (similar to
ServiceManager).

> Yarn native service classes renaming for easier development? 
> -------------------------------------------------------------
>
>                 Key: YARN-8084
>                 URL: https://issues.apache.org/jira/browse/YARN-8084
>             Project: Hadoop YARN
>          Issue Type: Task
>            Reporter: Wangda Tan
>            Priority: Major
>
> There're a couple of classes with same name exists in YARN native service. Such as: 
> 1) ...service.component.Component and api.records.Component.
> This makes harder when development in IDE since clash of class name forces to use full
qualified class name.
> Similarly in API definition:
> ...service.api.records:
> Container/ContainerState/Resource/ResourceInformation. How about rename them to:
> ServiceContainer/ServiceContainerState/ServiceResource/ServiceResourceInformation?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message