hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7346) Add a profile to allow optional compilation for ATSv2 with HBase-2.0
Date Thu, 01 Mar 2018 21:19:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16382652#comment-16382652
] 

Sean Busbey commented on YARN-7346:
-----------------------------------

Sorry, still catching up on things and haven't gotten to dig in here yet. but one quick bit:

{quote}
The findbugs & javadocs from yetus will fail for one hbase module when the compilation
profile is set for the other hbase version. But we can check the jenkins builds for patches
for each hbase version and confirm that the patches are good for their respective hbase versions.
{quote}

We should fix this by updating the Hadoop personality so that we only run in each module with
an appropriate profile active

> Add a profile to allow optional compilation for ATSv2 with HBase-2.0
> --------------------------------------------------------------------
>
>                 Key: YARN-7346
>                 URL: https://issues.apache.org/jira/browse/YARN-7346
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Ted Yu
>            Assignee: Haibo Chen
>            Priority: Major
>         Attachments: YARN-7346.00.patch, YARN-7346.01.patch, YARN-7346.02.patch, YARN-7346.03-incremental.patch,
YARN-7346.03.patch, YARN-7346.04-incremental.patch, YARN-7346.04.patch, YARN-7346.05.patch,
YARN-7346.06.patch, YARN-7346.07.patch, YARN-7346.08.patch, YARN-7346.prelim1.patch, YARN-7346.prelim2.patch,
YARN-7581.prelim.patch
>
>
> When compiling hadoop-yarn-server-timelineservice-hbase against 2.0.0-alpha3, I got the
following errors:
> [https://pastebin.com/Ms4jYEVB]
> This issue is to fix the compilation errors.
> The scope of the Jira is to add a profile to allow optional compilation for ATSv2 with
HBase2.0. The default compilation for trunk will still be for hbase 1.2.6. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message