hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohith Sharma K S (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7346) Add a profile to compile ATSv2 with HBase-2.0
Date Thu, 01 Mar 2018 12:57:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16381951#comment-16381951
] 

Rohith Sharma K S commented on YARN-7346:
-----------------------------------------

{quote}I'd like to see everything under control before it goes into trunk though; that's get
javadocs and findbugs to shut up
{quote}
By default yetus runs for hbase-1 profile which is default. This is causing findbug and java
doc errors for hbase-2 modules. We can produce a findbug and java doc report for HBase-2 profile
separately and can be attached to JIRA as a proof. But if someone expect that jenkins has
to run for both hbase-1 and hbase-2 profile all the time then really I don't have solution.
IIUC from other projects like Tez, jenkins runs for single profile always but Yetus is running
for modular compilation which is generating findbug and java doc errors.
{quote}setting the hbase-2 profile will allow the rest of Hadoop to build with guava.version=21.0?
{quote}
This is something we have to discuss/test irrespective of HBase-2 profile that compiles against
HBase-2.0-beta1 which is doing in this JIRA. I am not sure why HADOOP-15272 depends on this
JIRA! ATSv2 is already uses Hbase-1.2.6 as back end and uses guava 11. 

> Add a profile to compile ATSv2 with HBase-2.0
> ---------------------------------------------
>
>                 Key: YARN-7346
>                 URL: https://issues.apache.org/jira/browse/YARN-7346
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Ted Yu
>            Assignee: Haibo Chen
>            Priority: Major
>         Attachments: YARN-7346.00.patch, YARN-7346.01.patch, YARN-7346.02.patch, YARN-7346.03-incremental.patch,
YARN-7346.03.patch, YARN-7346.04-incremental.patch, YARN-7346.04.patch, YARN-7346.05.patch,
YARN-7346.06.patch, YARN-7346.07.patch, YARN-7346.08.patch, YARN-7346.prelim1.patch, YARN-7346.prelim2.patch,
YARN-7581.prelim.patch
>
>
> When compiling hadoop-yarn-server-timelineservice-hbase against 2.0.0-alpha3, I got the
following errors:
> https://pastebin.com/Ms4jYEVB
> This issue is to fix the compilation errors.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message