hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohith Sharma K S (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7346) Fix compilation errors against hbase2 beta release
Date Mon, 05 Feb 2018 09:46:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16352187#comment-16352187

Rohith Sharma K S commented on YARN-7346:

Update : As we discussed in last ATSv2 weekly call([~haibochen] [~vrushalic] [~varun_saxena]),
decided to support conditional compilation so that ATSv2 should support hbase-1.2.6 which
is already release along with Hadoop GA and HBase-2 as well. Currently all the hbase code
are embedded in single jar. To support conditional compilation, straight forward approach
is  create another module which picks up if Hbase version is 2.0. But issue with this approach
is duplicated code exist on both modules. 

After further discussion, we also thought of splitting into multiple jars such as *hadoop-yarn-server-timelineservice-hbase-common.jar*
*hadoop-yarn-server-timelineservice-hbase-reader.jar* *hadoop-yarn-server-timelineservice-hbase-collector.jar*
so that HBase co-processor code resides on collector jar which has co-processor modifications.
Doing this brings out we can create any number of module for collectors if HBase changes any
But cons from this approach is how does existing upgrade is handled? We also need to analyze
running HBase with older timelineservice co processor jar and collector running with newer
jars causes any issue provided we still maintain same class names. 

[~haibochen] [~vrushalic] feel free to add more point if I have missed any. 

> Fix compilation errors against hbase2 beta release
> --------------------------------------------------
>                 Key: YARN-7346
>                 URL: https://issues.apache.org/jira/browse/YARN-7346
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Ted Yu
>            Assignee: Vrushali C
>            Priority: Major
>         Attachments: YARN-7346.00.patch, YARN-7346.01.patch, YARN-7346.prelim1.patch,
YARN-7346.prelim2.patch, YARN-7581.prelim.patch
> When compiling hadoop-yarn-server-timelineservice-hbase against 2.0.0-alpha3, I got the
following errors:
> https://pastebin.com/Ms4jYEVB
> This issue is to fix the compilation errors.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message