hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-6619) AMRMClient Changes to use the PlacementConstraint and SchcedulingRequest objects
Date Wed, 17 Jan 2018 00:12:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-6619?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16328034#comment-16328034

Wangda Tan commented on YARN-6619:

1) AMRMClient.java

addPlacementConstraint: maybe change a better name, such as addDefaultPlacementConstraintMapping(...).
Existing naming is a bit confused with addSchedulingRequests since PlacementConstraint is
a part of SchedulingRequest.

Mark both methods to unstable.

Same applies to AMRMClientAsync.java changes.

2) AMRMClientImpl.java

I found the implementation uses the similar approach of ResourceRequest which has a local
cached pending request and deduct pending request for container allocation, etc. We know the
downside of this approach is it has local states and sometimes it could receive extra containers
from RM.

I propose to simplify this approach: 
- Don't cache local requests, all requests will be cleared after sending to RM.
- Because of above, don't need to do anything after container received.

3) Test cases failure related?

> AMRMClient Changes to use the PlacementConstraint and SchcedulingRequest objects
> --------------------------------------------------------------------------------
>                 Key: YARN-6619
>                 URL: https://issues.apache.org/jira/browse/YARN-6619
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Arun Suresh
>            Assignee: Arun Suresh
>            Priority: Major
>         Attachments: YARN-6619-YARN-6592.001.patch, YARN-6619-YARN-6592.002.patch
> Opening this JIRA to track changes needed in the AMRMClient to incorporate the PlacementConstraint
and SchedulingRequest objects

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message