hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7437) Give SchedulingPlacementSet to a better name.
Date Fri, 03 Nov 2017 16:49:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7437?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16237896#comment-16237896
] 

Wangda Tan commented on YARN-7437:
----------------------------------

[~asuresh]/[~kkaranasos]/[~subru]. 

How about rename it to PlacementStrategy(or AppPlacementStrategy). And rename LocalitySchedulingPlacementSet
to LocalityPlacementStrategy? Or any better suggestions?

> Give SchedulingPlacementSet to a better name.
> ---------------------------------------------
>
>                 Key: YARN-7437
>                 URL: https://issues.apache.org/jira/browse/YARN-7437
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Wangda Tan
>            Assignee: Wangda Tan
>            Priority: Major
>
> Currently, the SchedulingPlacementSet is very confusing. Here're its responsibilities:
> 1) Store ResourceRequests. (Or SchedulingRequest after YARN-6592).
> 2) Decide order of nodes to allocate when there're multiple node candidates.
> 3) Decide if we should reject node for given requests.
> 4) Store any states/cache can help make decision for #2/#3



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message