hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohith Sharma K S (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7375) NPE in the RM Webapp when HA is enabled and the active RM fails
Date Mon, 23 Oct 2017 05:47:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7375?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16214674#comment-16214674
] 

Rohith Sharma K S commented on YARN-7375:
-----------------------------------------

thanks [~csingh] for reporting this issue. You are right, YARN-6871 caused this issue. Can
you give quick fix for this? 

> NPE in the RM Webapp when HA is enabled and the active RM fails
> ---------------------------------------------------------------
>
>                 Key: YARN-7375
>                 URL: https://issues.apache.org/jira/browse/YARN-7375
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Chandni Singh
>
> Caused by: java.lang.NullPointerException
>         at org.apache.hadoop.yarn.server.resourcemanager.webapp.dao.AppInfo.<init>(AppInfo.java:327)
>         at org.apache.hadoop.yarn.server.resourcemanager.webapp.dao.AppInfo.<init>(AppInfo.java:133)
>         at org.apache.hadoop.yarn.server.resourcemanager.webapp.RMAppAttemptBlock.createResourceRequestsTable(RMAppAttemptBlock.java:77)
>         at org.apache.hadoop.yarn.server.resourcemanager.webapp.RMAppAttemptBlock.createTablesForAttemptMetrics(RMAppAttemptBlock.java:280)
>         at org.apache.hadoop.yarn.server.webapp.AppAttemptBlock.render(AppAttemptBlock.java:153)
>         at org.apache.hadoop.yarn.webapp.view.HtmlBlock.render(HtmlBlock.java:69)
>         at org.apache.hadoop.yarn.webapp.view.HtmlBlock.renderPartial(HtmlBlock.java:79)
>         at org.apache.hadoop.yarn.webapp.View.render(View.java:235)
>         at org.apache.hadoop.yarn.webapp.view.HtmlPage$Page.subView(HtmlPage.java:49)
>         at org.apache.hadoop.yarn.webapp.hamlet2.HamletImpl$EImp._v(HamletImpl.java:117)
>         at org.apache.hadoop.yarn.webapp.hamlet2.Hamlet$TD.__(Hamlet.java:848)
>         at org.apache.hadoop.yarn.webapp.view.TwoColumnLayout.render(TwoColumnLayout.java:71)
>         at org.apache.hadoop.yarn.webapp.view.HtmlPage.render(HtmlPage.java:82)
>         at org.apache.hadoop.yarn.webapp.Controller.render(Controller.java:212)
>         at org.apache.hadoop.yarn.server.resourcemanager.webapp.RmController.appattempt(RmController.java:58)
> Steps:
> 1. RM HA is enabled
> 2. Started a service 
> 3. Active RM failed. 
> 4. Switched to the Web UI of Standby RM 
> 5. Clicked to view the containers of the previous started application and landed to an
error page.
> 6. The NPE mentioned above was found in the standby RM logs



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message