hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Yang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-7323) Data structure update in service REST API
Date Fri, 13 Oct 2017 21:22:00 GMT

     [ https://issues.apache.org/jira/browse/YARN-7323?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Eric Yang updated YARN-7323:
----------------------------
    Description: 
Unix terminology implies daemon process, such as httpd as a service.  In Hadoop terminology,
hdfs is a file system service, and hdfs has various components such as namenode, journal nodes,
and datanodes.  YARN service data model was more closely describing daemon process as a service.
 This JIRA propose to remap the YARN service data model to align with Hadoop terminology.
 Service is composed of a collection of components.  Component is either a unix process or
docker container.
  
Data structure for Yarnfile organized launched_command and state at Service level, but the
grouping definition was following Hadoop terminology.  For clarity, we will change data structure
to match Hadoop terminology.  State and launch commands are moved to component level.

  was:Data structure for Yarnfile organized state at service level.  


> Data structure update in service REST API
> -----------------------------------------
>
>                 Key: YARN-7323
>                 URL: https://issues.apache.org/jira/browse/YARN-7323
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Jian He
>            Assignee: Jian He
>         Attachments: YARN-7323.yarn-native-services.01.patch, YARN-7323.yarn-native-services.02.patch
>
>
> Unix terminology implies daemon process, such as httpd as a service.  In Hadoop terminology,
hdfs is a file system service, and hdfs has various components such as namenode, journal nodes,
and datanodes.  YARN service data model was more closely describing daemon process as a service.
 This JIRA propose to remap the YARN service data model to align with Hadoop terminology.
 Service is composed of a collection of components.  Component is either a unix process or
docker container.
>   
> Data structure for Yarnfile organized launched_command and state at Service level, but
the grouping definition was following Hadoop terminology.  For clarity, we will change data
structure to match Hadoop terminology.  State and launch commands are moved to component level.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message