hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gour Saha (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7323) Data structure update in service REST API
Date Mon, 16 Oct 2017 23:46:02 GMT

    [ https://issues.apache.org/jira/browse/YARN-7323?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16206787#comment-16206787
] 

Gour Saha commented on YARN-7323:
---------------------------------

{quote}
Data structure for Yarnfile organized launched_command and state at Service level, but the
grouping definition was following Hadoop terminology. For clarity, we will change data structure
to match Hadoop terminology. State and launch commands are moved to component level.
{quote}
[~eyang], launch command was always there at component-level. It was there at the service-level
as well to support simple no-component services. This patch is killing the concept of simple
no-component service and forcing the user to create a component even for the simplest case.
Also, state is still there at the service-level along with component-level. Hence, the above
description does not match with what the assignee of this Jira and the author of the patch
intends to do. Next time, please consult with the assignee/patch-author before making changes
to the description OR make your suggestions as comments rather than re-writing description
OR request for ownership change of the jira and then make changes to the description and provide
your patch.


> Data structure update in service REST API
> -----------------------------------------
>
>                 Key: YARN-7323
>                 URL: https://issues.apache.org/jira/browse/YARN-7323
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Jian He
>            Assignee: Jian He
>         Attachments: YARN-7323.yarn-native-services.01.patch, YARN-7323.yarn-native-services.02.patch,
YARN-7323.yarn-native-services.03.patch
>
>
> Unix terminology implies daemon process, such as httpd as a service.  In Hadoop terminology,
hdfs is a file system service, and hdfs has various components such as namenode, journal nodes,
and datanodes.  YARN service data model was more closely describing daemon process as a service.
 This JIRA propose to remap the YARN service data model to align with Hadoop terminology.
 Service is composed of a collection of components.  Component is either a unix process or
docker container.
>   
> Data structure for Yarnfile organized launched_command and state at Service level, but
the grouping definition was following Hadoop terminology.  For clarity, we will change data
structure to match Hadoop terminology.  State and launch commands are moved to component level.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message