hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7138) Fix incompatible API change for YarnScheduler involved by YARN-5221
Date Thu, 12 Oct 2017 18:04:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7138?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16202358#comment-16202358
] 

Wangda Tan commented on YARN-7138:
----------------------------------

[~rchiang], I'm fine with doing that.

> Fix incompatible API change for YarnScheduler involved by YARN-5221
> -------------------------------------------------------------------
>
>                 Key: YARN-7138
>                 URL: https://issues.apache.org/jira/browse/YARN-7138
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: scheduler
>            Reporter: Junping Du
>            Priority: Critical
>
> From JACC report for 2.8.2 against 2.7.4, it indicates that we have incompatible changes
happen in YarnScheduler:
> {noformat}
> hadoop-yarn-server-resourcemanager-2.7.4.jar, YarnScheduler.class
> package org.apache.hadoop.yarn.server.resourcemanager.scheduler
> YarnScheduler.allocate ( ApplicationAttemptId p1, List<ResourceRequest> p2, List<ContainerId>
p3, List<String> p4, List<String> p5 ) [abstract]  :  Allocation 
> {noformat}
> The root cause is YARN-5221. We should change it back or workaround this by adding back
original API (mark as deprecated if not used any more).



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message