hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ray Chiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7219) Fix AllocateRequestProto difference between branch-2/branch-2.8 and trunk
Date Tue, 19 Sep 2017 20:55:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7219?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16172328#comment-16172328
] 

Ray Chiang commented on YARN-7219:
----------------------------------

Will updating the update_requests field to 7 will be enough to fix the compatibility issue?
 [~asuresh] or [~djp], any comment?

> Fix AllocateRequestProto difference between branch-2/branch-2.8 and trunk
> -------------------------------------------------------------------------
>
>                 Key: YARN-7219
>                 URL: https://issues.apache.org/jira/browse/YARN-7219
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: yarn
>    Affects Versions: 3.0.0-beta1
>            Reporter: Ray Chiang
>            Priority: Critical
>
> For yarn_service_protos.proto, we have the following code in
> (branch-2.8.0, branch-2.8, branch-2)
> {noformat}
> message AllocateRequestProto {
>   repeated ResourceRequestProto ask = 1;
>   repeated ContainerIdProto release = 2;
>   optional ResourceBlacklistRequestProto blacklist_request = 3;
>   optional int32 response_id = 4;
>   optional float progress = 5;
>   repeated ContainerResourceIncreaseRequestProto increase_request = 6;
>   repeated UpdateContainerRequestProto update_requests = 7;
> }
> {noformat}
> For yarn_service_protos.proto, we have the following code in
> (trunk)
> {noformat}
> message AllocateRequestProto {
>   repeated ResourceRequestProto ask = 1;
>   repeated ContainerIdProto release = 2;
>   optional ResourceBlacklistRequestProto blacklist_request = 3;
>   optional int32 response_id = 4;
>   optional float progress = 5;
>   repeated UpdateContainerRequestProto update_requests = 6;
> }
> {noformat}
> Notes
> * YARN-3866 was the original JIRA for container resizing.
> * YARN-5221 is what introduced the incompatible change.
> * In branch-2/branch-2.8/branch-2.8.0, this protobuf change was undone by "Addendum patch
to YARN-3866: fix incompatible API change."
> * There was a similar API fix done in YARN-6071.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message