hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (YARN-7136) Additional Performance Improvement for Resource Profile Feature
Date Mon, 04 Sep 2017 04:47:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7136?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16152116#comment-16152116
] 

Wangda Tan edited comment on YARN-7136 at 9/4/17 4:46 AM:
----------------------------------------------------------

Thanks [~templedf] for review. 

All good points, for two following items:

bq. In ResourceInformation should the constants be called URIs? Aren't they just names?
I think we can support the URI like "yarn.io/gpu" or "example.com/resource-x" as the original
design. So do you think if the "URI" is more appropriate than "name"?

bq. is it really worth adding the length to the signature? You're retrieving the value in
all the other methods, so why not there as well?
Since get length retrieves a volatile field, so we should avoid such call as much as possible.
What I try to do is only get it once for every public method.

Will update patch once you post rest comments.


was (Author: leftnoteasy):
Thanks [~templedf] for review. 

All good points, 

bq. In ResourceInformation should the constants be called URIs? Aren't they just names?
I think we can support the URI like "yarn.io/gpu" or "example.com/resource-x" as the original
design. So do you think if the "URI" is more appropriate than "name"?

bq. is it really worth adding the length to the signature? You're retrieving the value in
all the other methods, so why not there as well?
Since get length retrieves a volatile field, so we should avoid such call as much as possible.
What I try to do is only get it once for every public method.

> Additional Performance Improvement for Resource Profile Feature
> ---------------------------------------------------------------
>
>                 Key: YARN-7136
>                 URL: https://issues.apache.org/jira/browse/YARN-7136
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager, resourcemanager
>            Reporter: Wangda Tan
>            Assignee: Wangda Tan
>            Priority: Critical
>         Attachments: YARN-7136.001.patch, YARN-7136.YARN-3926.001.patch, YARN-7136.YARN-3926.002.patch,
YARN-7136.YARN-3926.003.patch, YARN-7136.YARN-3926.004.patch, YARN-7136.YARN-3926.005.patch,
YARN-7136.YARN-3926.006.patch, YARN-7136.YARN-3926.007.patch
>
>
> This JIRA is plan to add following misc perf improvements:
> 1) Use final int in Resources/ResourceCalculator to cache #known-resource-types. (Significant
improvement).
> 2) Catch Java's ArrayOutOfBound Exception instead of checking array.length every time.
(Significant improvement).
> 3) Avoid setUnit validation (which is a HashSet lookup) when initialize default Memory/VCores
ResourceInformation (Significant improvement).
> 4) Avoid unnecessary loop array in Resource#toString/hashCode. (Some improvement).
> 5) Removed readOnlyResources in BaseResource. (Minor improvement).
> 6) Removed enum: MandatoryResources, use final integer instead. (Minor improvement).



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message