hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Billie Rinaldi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-7091) Rename application to service in yarn-native-services
Date Thu, 24 Aug 2017 14:55:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-7091?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16140119#comment-16140119
] 

Billie Rinaldi commented on YARN-7091:
--------------------------------------

[~jianhe], I am very happy about the effects of these changes. I think standardizing on the
name "service" in yarn-native-services will really clarify our terminology. A few comments
on patch 01:
* regarding hadoop-yarn-services-core, are other modules planned under hadoop-yarn-services?
If not, we could combine these into a single module
* change YARN_SERVICESAPI_OPTS in yarn-env.sh to YARN_APISERVER_OPTS
* change deleteApplication / updateApplication log statements to delete service / update service
in ApplicationApiService. Also, the variable name updateAppData should be changed (I am not
as concerned about the variable appName, since it’s also the YARN app name)
* rename ApplicationApiService and ApplicationApiWebApp to ApiServer and ApiWebApp or ApiServerWebApp
* in the yaml, check for usages of “an service” -- it should be “a service.” For “Get
an service details” just remove “an.” Check for uses of “app” -- “app-component”
should be “component,” other usages of “app” should change to “service” (but look
out for “an app”) -- except webapp which is fine. The API records java classes have the
same issues (since they are generated from the yaml)
* (unrelated) in the yaml, we should mention the format reqs for component name and service
name
* rename ServiceApiUtil methods with “application” in the name (loadApplication, validateAndResolveApplication,
etc.)
* ActionListArgs and SliderActions have “an service”
* there are some git artifacts in the patch - ContainerState.java~HEAD, ContainerState.java~HEAD_0,
and a couple other versions of ContainerState

> Rename application to service in yarn-native-services
> -----------------------------------------------------
>
>                 Key: YARN-7091
>                 URL: https://issues.apache.org/jira/browse/YARN-7091
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Jian He
>            Assignee: Jian He
>         Attachments: YARN-7091.yarn-native-services.01.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message