hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Templeton (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-6727) Improve getQueueUserAcls API to query for specific queue and user
Date Tue, 29 Aug 2017 18:42:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-6727?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16145881#comment-16145881
] 

Daniel Templeton commented on YARN-6727:
----------------------------------------

Thanks for the patch.  Here are my comments:

# Minor nit: this _if_:{code}      if (!applicationsACLsManager.isAdmin(currentUGI) &&
userName != null
          && !userName.equals(currentUGI.getShortUserName())) {{code} would be more
efficient if you did the null check first.
# I don't like ternary operators unless they actually make things more readable.  This one:{code}
     UserGroupInformation ugi = userName == null ?
          currentUGI :
          UserGroupInformation.createRemoteUser(userName);{code} doesn't do it for me.  It's
much clearer to me to reuse {{currentUGI}}:{code}      if (userName != null) {
        currentUGI = UserGroupInformation.createRemoteUser(userName);
      }{code}
# You could apply the diamond operator in several places in {{QueueACLsManager}}.
# I prefer {{x != null}} to {{null != x}}.
# Any way we can avoid doing the string math in {{getShortQueueName()}}?
# Please add failure messages to the {{assertTrue()}} calls in the test code.

> Improve getQueueUserAcls API to query for  specific queue and user
> ------------------------------------------------------------------
>
>                 Key: YARN-6727
>                 URL: https://issues.apache.org/jira/browse/YARN-6727
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Bibin A Chundatt
>            Assignee: Bibin A Chundatt
>         Attachments: YARN-6727.001.patch, YARN-6727.002.patch, YARN-6727.003.patch, YARN-6727.WIP.patch
>
>
> Currently {{ApplicationClientProtocol#getQueueUserAcls}} return data for all the queues
available in scheduler for user.
> User wants to know whether he has rights of a particular queue only. For systems with
5K queues returning all queues list is not efficient.
> Suggested change: support additional parameters *userName and queueName* as optional.
Admin user should be able to query other users ACL for a particular queueName.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message