hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-6709) Root privilege escalation in experimental Docker support
Date Mon, 28 Aug 2017 18:09:00 GMT

     [ https://issues.apache.org/jira/browse/YARN-6709?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Allen Wittenauer updated YARN-6709:
-----------------------------------
    Release Note: CVE-2017-7669 / YARN's Docker support did not do enough input validation.
 This allowed a root level escalation from an ordinary user account. 

> Root privilege escalation in experimental Docker support
> --------------------------------------------------------
>
>                 Key: YARN-6709
>                 URL: https://issues.apache.org/jira/browse/YARN-6709
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: nodemanager, security
>    Affects Versions: 2.8.0, 3.0.0-alpha1, 3.0.0-alpha2
>            Reporter: Allen Wittenauer
>            Assignee: Varun Vasudev
>            Priority: Blocker
>              Labels: security
>             Fix For: 2.8.1, 3.0.0-alpha3
>
>
> YARN-3853 and friends do not do enough input validation. They allow a user to do escalate
privileges at root trivially. See https://effectivemachines.com/2017/06/02/docker-security-in-framework-managed-multi-user-environments/
for more information.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message