hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gergely Novák (JIRA) <j...@apache.org>
Subject [jira] [Commented] (YARN-6505) Define the strings used in SLS JSON input file format
Date Tue, 01 Aug 2017 09:18:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-6505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16108614#comment-16108614

Gergely Novák commented on YARN-6505:

Thanks [~yufeigu] for your comments, I addressed them all:
# IMO for consistency we have to include the prefix (container, or task, see point 3) as all
the other parameters (start.ms, end.ms, etc.) has it. But you are right, this is an incompatible
change, so I added that label.
# Fixed
# Changed all the task related input configurations to "task." and "TASK_XXX". I'm not sure
if you suggested to change only the variable name or the JSON as well, I went with the latter
since it is already an incompatible change and - as you suggested - I find it cleaner and
more logical. 

The unit tests passed locally and on Jenkins, too.

> Define the strings used in SLS JSON input file format
> -----------------------------------------------------
>                 Key: YARN-6505
>                 URL: https://issues.apache.org/jira/browse/YARN-6505
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: scheduler-load-simulator
>            Reporter: Yufei Gu
>            Assignee: Gergely Novák
>              Labels: incompatible, newbie
>         Attachments: YARN-6505.001.patch, YARN-6505.002.patch, YARN-6505.003.patch
> We could put them in a Java file like what YarnConfiguration does.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message