hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sunil G (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (YARN-6855) CLI Proto Modifications to support Node Attributes
Date Tue, 25 Jul 2017 02:51:03 GMT

    [ https://issues.apache.org/jira/browse/YARN-6855?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16099409#comment-16099409
] 

Sunil G edited comment on YARN-6855 at 7/25/17 2:50 AM:
--------------------------------------------------------

Thanks [~naganarasimha_gr@apache.org] for the effort.

Few comments
In +{{NodeAttribute}}+, +{{NodeAttributeType}}+, +{{NodeIdToAttributes}}+ and +{{NodesToAttributesMappingRequest}}+
# I think lets make this class as Unstable from Evolving as its a new api itself. In the course,
we can make to Evolving.
# please add more java doc.
# I think its too early to place Stable for NodeAttributeType. Since its public and its an
enum, is its ok if we mark interface stability with Unstable/Evolving to start with.

In +{{NodesToAttributesMappingRequest}}+ and +{{yarn_server_resourcemanager_service_protos.proto}}+
# I think {{operation}} could be an enum here. String may be too generic and complex to do
type checks.

In general
# {{NodeAttributePBImpl#equals}} has some duplicate code.
# in {{NodesToAttributesMappingRequestPBImpl}}, {{operation}} needs some change if above comments
is accepted.

I will take a second look and will share comments if any.




was (Author: sunilg):
Thanks [~naganarasimha_gr@apache.org] for the effort.

Few comments
In +{{NodeAttribute}}+, +{{NodeAttributeType}}+, +{{NodeIdToAttributes}}+ and +{{NodesToAttributesMappingRequest}}+
# I think lets make this class as Unstable from Evolving as its a new api itself. In the course,
we can make to Evolving.
# please add more java doc.
# I think its too early to place Stable for NodeAttributeType. Since its public and its an
enum, is its ok if we mark interface stability with Unstable/Evolving to start with.

In +{{NodesToAttributesMappingRequest}}+ and +{{yarn_server_resourcemanager_service_protos.proto}}+
# I think {{operation}} could be an enum here. String may be too generic and complex to do
type checks.

In general
# {{NodeAttributePBImpl#equals}} has some duplicate code.
# 



> CLI Proto Modifications to support Node Attributes
> --------------------------------------------------
>
>                 Key: YARN-6855
>                 URL: https://issues.apache.org/jira/browse/YARN-6855
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: api, capacityscheduler, client
>            Reporter: Naganarasimha G R
>            Assignee: Naganarasimha G R
>         Attachments: YARN-6855-YARN-3409.001.patch, YARN-6855-YARN-3409.002.patch, YARN-6855-YARN-3409.003.patch
>
>
> This jira focuses only on the proto modifications required for the CLI



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message