hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Lowe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-6810) YARN localizer has to validate the mapreduce.tar.gz present in cache before using it
Date Wed, 12 Jul 2017 14:39:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-6810?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16084072#comment-16084072
] 

Jason Lowe commented on YARN-6810:
----------------------------------

This looks like a duplicate of YARN-6315.

> YARN localizer has to validate the mapreduce.tar.gz present in cache before using it
> ------------------------------------------------------------------------------------
>
>                 Key: YARN-6810
>                 URL: https://issues.apache.org/jira/browse/YARN-6810
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: nodemanager
>    Affects Versions: 2.7.3
>            Reporter: Prabhu Joseph
>
> When a localized mapreduce.tar.gz is corrupt and zero bytes, all MapReduce jobs fails
on the cluster with "Error: Could not find or load main class org.apache.hadoop.mapreduce.v2.app.MRAppMaster
" as it uses corrupt mapreduce.tar.gz. YARN Localizer has to check if the existing mapreduce.tar.gz
is a valid file before using it.
>  



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message