hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-6706) Refactor ContainerScheduler to make oversubscription change easier
Date Mon, 10 Jul 2017 18:31:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-6706?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16080813#comment-16080813
] 

Karthik Kambatla commented on YARN-6706:
----------------------------------------

I feel we should get this into trunk directly instead of YARN-1011 branch.

The current patch looks okay, Can we add a few more things:
# Make ResourceUtilizationTracker pluggable. That way, we could use a different tracker when
oversubscription is enabled.
# ContainerScheduler
##  Why do we need maxOppQueueLength given queuingLimit?
## Is there value in splitting runningContainers into runningGuaranteed and runningOpportunistic?
## getOpportunisticContainersStatus method implementation feels awkward. How about capturing
the state in the field here, and have metrics etc. pull from here? 
## startContainersFromQueue: Local variable resourcesAvailable is unnecessary
# OpportunisticContainersStatus
## Let us clearly differentiate between allocated, used and utilized. Maybe, we should rename
current *Used* methods to *Allocated*?
## I prefer either full name Opportunistic (in method) or Opp (shortest name that makes sense).
Opport is neither short nor fully descriptive.
## Have we considered folding ContainerQueuingLimit class into this?

/cc [~asuresh] and [~kkaranasos]

> Refactor ContainerScheduler to make oversubscription change easier
> ------------------------------------------------------------------
>
>                 Key: YARN-6706
>                 URL: https://issues.apache.org/jira/browse/YARN-6706
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>    Affects Versions: 3.0.0-alpha3
>            Reporter: Haibo Chen
>            Assignee: Haibo Chen
>         Attachments: YARN-6706-YARN-1011.00.patch, YARN-6706-YARN-1011.01.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message