hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (YARN-6033) Add support for sections in container-executor configuration file
Date Thu, 06 Jul 2017 18:32:00 GMT

    [ https://issues.apache.org/jira/browse/YARN-6033?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16077029#comment-16077029
] 

Wangda Tan edited comment on YARN-6033 at 7/6/17 6:31 PM:
----------------------------------------------------------

Thanks [~vvasudev] for the patch. I just took a look at the patch, in general it is in good
shape, in addition to the configuration section itself, it also brings gtest framework, which
will be much easier to add tests in the future.

Some comments:
1) It's better to move 
{code}
struct section executor_cfg = {.size=0, .sectiondetails=NULL};
{code} and 
{code}
struct configuration CFG = {.size=0, .sections=NULL};
{code}
>From container-executor.c to configurations.c. And add getter/setter method to configuration.h.
I think we should not couple life cycle of configuration and container-executor since we could
add other modules beyond container-executor in the new design.
2) some rename suggestions: 
- sectionentry: is it better to call {{kv_pair}}? 
- sectiondetails: if you agree with above, how about rename it to {{kv_pairs}}?

 [~sunilg].


was (Author: leftnoteasy):
Thanks [~vvasudev] for the patch. I just took a look at the patch, in general it is in good
shape, in addition to the configuration section itself, it also brings gtest framework, which
will be much easier to add tests in the future.

Some comments:
1) It's better to move {{struct section executor_cfg = {.size=0, .sectiondetails=NULL};}}
and {{struct configuration CFG = {.size=0, .sections=NULL};}} from container-executor.c to
configurations.c. And add getter/setter method to configuration.h. I think we should not couple
life cycle of configuration and container-executor since we could add other modules beyond
container-executor in the new design.
2) some rename suggestions: 
- sectionentry: is it better to call {{kv_pair}}? 
- sectiondetails: if you agree with above, how about rename it to {{kv_pairs}}?

 [~sunilg].

> Add support for sections in container-executor configuration file
> -----------------------------------------------------------------
>
>                 Key: YARN-6033
>                 URL: https://issues.apache.org/jira/browse/YARN-6033
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager
>            Reporter: Varun Vasudev
>            Assignee: Varun Vasudev
>         Attachments: YARN-6033-YARN-5673.001.patch, YARN-6033-YARN-5673.002.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message