hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Lowe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-6603) NPE in RMAppsBlock
Date Mon, 15 May 2017 20:21:04 GMT

    [ https://issues.apache.org/jira/browse/YARN-6603?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16011258#comment-16011258
] 

Jason Lowe commented on YARN-6603:
----------------------------------

Same type of line in question as YARN-4763:
{code}
      RMAppAttempt appAttempt =
          rm.getRMContext().getRMApps().get(appAttemptId.getApplicationId())
              .getAppAttempts().get(appAttemptId);
{code}

I believe the issue can occur if an app gets removed form the RMContext after the app reports
are gathered but before the loop ends up trying to lookup the app.  In that case {{rm.getRMContext().getRMApps().get(appAttemptId.getApplicationId())}}
is going to return null and a subsequent call to getAppAttempts() is going to trigger the
NPE.

> NPE in RMAppsBlock
> ------------------
>
>                 Key: YARN-6603
>                 URL: https://issues.apache.org/jira/browse/YARN-6603
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: resourcemanager
>    Affects Versions: 2.8.0
>            Reporter: Jason Lowe
>
> We are seeing an intermittent NPE when the RM is trying to render the /cluster URI.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message