hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohith Sharma K S (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-6564) RM service is shutting down when ATS v2 is enabled
Date Fri, 05 May 2017 14:09:04 GMT

    [ https://issues.apache.org/jira/browse/YARN-6564?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15998381#comment-15998381
] 

Rohith Sharma K S commented on YARN-6564:
-----------------------------------------

I tried using hbase-shaded-client jar but RM start up itself failing with following error.
Though guice jar is present in classpath, hbase shaded client jar is trying to load guava
dependencies from shaded jar only. This appears like building hbase shaded client jar has
issue. I am not sure somebody had tried using shaded since HBASE-13889. 
{noformat}
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/hadoop/hbase/shaded/com/google/inject/servlet/ServletModule
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
        .......
Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hbase.shaded.com.google.inject.servlet.ServletModule
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
{noformat}



> RM service is shutting down when ATS v2 is enabled
> --------------------------------------------------
>
>                 Key: YARN-6564
>                 URL: https://issues.apache.org/jira/browse/YARN-6564
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: resourcemanager
>            Reporter: Akhil PB
>            Assignee: Rohith Sharma K S
>            Priority: Critical
>
> RM shutting down with following error
> {code}
> 2017-05-05 14:41:06,056 FATAL org.apache.hadoop.yarn.event.AsyncDispatcher: Error in
dispatcher thread
> java.lang.IllegalAccessError: tried to access method com.google.common.base.Stopwatch.<init>()V
from class org.apache.hadoop.hbase.zookeeper.MetaTableLocator
>         at org.apache.hadoop.hbase.zookeeper.MetaTableLocator.blockUntilAvailable(MetaTableLocator.java:604)
>         at org.apache.hadoop.hbase.zookeeper.MetaTableLocator.blockUntilAvailable(MetaTableLocator.java:588)
>         at org.apache.hadoop.hbase.zookeeper.MetaTableLocator.blockUntilAvailable(MetaTableLocator.java:561)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message