hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Kanter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5894) fixed license warning caused by de.ruedigermoeller:fst:jar:2.24
Date Wed, 26 Apr 2017 00:53:04 GMT

    [ https://issues.apache.org/jira/browse/YARN-5894?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15983928#comment-15983928
] 

Robert Kanter commented on YARN-5894:
-------------------------------------

I did a diff of the jars before and after apply the patch.  It looks like upgrading FST to
2.50 also:
- Adds java-util 1.9.0
- Adds json-io 2.5.1
- Upgrades objenesis 2.1 to 2.5.1

{noformat}
< ./hadoop-yarn-project/target/hadoop-yarn-project-3.0.0-alpha3-SNAPSHOT/share/hadoop/yarn/lib/fst-2.24.jar
---
> ./hadoop-yarn-project/target/hadoop-yarn-project-3.0.0-alpha3-SNAPSHOT/share/hadoop/yarn/lib/fst-2.50.jar
1379a1382
> ./hadoop-yarn-project/target/hadoop-yarn-project-3.0.0-alpha3-SNAPSHOT/share/hadoop/yarn/lib/java-util-1.9.0.jar
1404a1408
> ./hadoop-yarn-project/target/hadoop-yarn-project-3.0.0-alpha3-SNAPSHOT/share/hadoop/yarn/lib/json-io-2.5.1.jar
1432c1436
< ./hadoop-yarn-project/target/hadoop-yarn-project-3.0.0-alpha3-SNAPSHOT/share/hadoop/yarn/lib/objenesis-2.1.jar
---
> ./hadoop-yarn-project/target/hadoop-yarn-project-3.0.0-alpha3-SNAPSHOT/share/hadoop/yarn/lib/objenesis-2.5.1.jar
{noformat}

Looks like the added libraries are Apache Licensed.  Can you just verify that there's no problem
if we upgrade objenesis?

> fixed license warning caused by de.ruedigermoeller:fst:jar:2.24
> ---------------------------------------------------------------
>
>                 Key: YARN-5894
>                 URL: https://issues.apache.org/jira/browse/YARN-5894
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: yarn
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Haibo Chen
>            Assignee: Haibo Chen
>            Priority: Blocker
>         Attachments: YARN-5894.00.patch
>
>
> The artifact de.ruedigermoeller:fst:jar:2.24, that ApplicationHistoryService depends
on,  shows its license being LGPL 2.1 in our license checking.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message