hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sunil G (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-6362) Build failure of yarn-ui profile
Date Fri, 17 Mar 2017 15:37:41 GMT

    [ https://issues.apache.org/jira/browse/YARN-6362?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15930149#comment-15930149
] 

Sunil G commented on YARN-6362:
-------------------------------

No.. Thanks very much for reporting. You are correct. We still have failures in local.

We checked and found that it is caused because of frontend-maven-plugin. We never mentioned
any version for this plugin, hence in ubuntu or mac, they pulled different versions. This
caused the failure in one and not in other.
{{<frontend-maven-plugin.version>1.1</frontend-maven-plugin.version>}}
This also has to be added to pom.xml along with your change.

But this has dependency to use 3.1 version of maven. But hadoop needs only a minimum of 3.0
maven. I ll check in detail

> Build failure of yarn-ui profile
> --------------------------------
>
>                 Key: YARN-6362
>                 URL: https://issues.apache.org/jira/browse/YARN-6362
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Kai Sasaki
>            Assignee: Kai Sasaki
>         Attachments: YARN-6362.01.patch
>
>
> Building yarn-ui module fails due to invalid npm-cli.js path.
> {code}
> $ mvn clean install -DskipTests -Dtar -Pdist  -Pyarn-ui
> {code}
> Failure of {{exec-maven-plugin}} in yarn-ui profile.
> {code}
> [INFO] --- exec-maven-plugin:1.3.1:exec (ember build) @ hadoop-yarn-ui ---
> module.js:327
>     throw err;
>     ^
> Error: Cannot find module '/Users/sasakikai/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node/npm/bin/npm-cli'
>     at Function.Module._resolveFilename (module.js:325:15)
>     at Function.Module._load (module.js:276:25)
>     at Function.Module.runMain (module.js:441:10)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message