hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Li Lu (JIRA)" <j...@apache.org>
Subject [jira] [Created] (YARN-6293) Investigate Java 7 compatibility for new YARN UI
Date Mon, 06 Mar 2017 21:40:33 GMT
Li Lu created YARN-6293:
---------------------------

             Summary: Investigate Java 7 compatibility for new YARN UI
                 Key: YARN-6293
                 URL: https://issues.apache.org/jira/browse/YARN-6293
             Project: Hadoop YARN
          Issue Type: Sub-task
            Reporter: Li Lu


Right now when trying the YARN new UI with Java 7, I can get the following warning:
{code}
[INFO] --- maven-enforcer-plugin:1.4.1:enforce (dist-enforce) @ hadoop-yarn-ui ---
[WARNING] Rule 1: org.apache.maven.plugins.enforcer.RequireJavaVersion failed with message:
Detected JDK Version: 1.7.0-67 is not in the allowed range [1.8,).
{code}

While right now this warning does not cause any troubles for trunk integration, when some
users would like to package the new UI with some branch-2 based code, the JDK requirement
would block the effort. So the question here is, is there any specific component in new UI
codebase that prevent us using Java 7? I remember it should be a JS based implementation,
right? 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message