hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5956) Refactor ClientRMService for unify error handling across apis
Date Sat, 25 Mar 2017 17:19:42 GMT

    [ https://issues.apache.org/jira/browse/YARN-5956?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15941799#comment-15941799
] 

Hudson commented on YARN-5956:
------------------------------

SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11462 (See [https://builds.apache.org/job/Hadoop-trunk-Commit/11462/])
YARN-5956. Refactor ClientRMService for unify error handling across (sunilg: rev cffea251be4b73ca16e5e11f0be2d22651330f73)
* (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ClientRMService.java
* (edit) hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/RMAuditLogger.java


> Refactor ClientRMService for unify error handling across apis
> -------------------------------------------------------------
>
>                 Key: YARN-5956
>                 URL: https://issues.apache.org/jira/browse/YARN-5956
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Kai Sasaki
>            Assignee: Kai Sasaki
>            Priority: Minor
>         Attachments: YARN-5956.01.patch, YARN-5956.02.patch, YARN-5956.03.patch, YARN-5956.04.patch,
YARN-5956.05.patch, YARN-5956.06.patch, YARN-5956.07.patch, YARN-5956.08.patch, YARN-5956.09.patch,
YARN-5956.10.patch, YARN-5956.11.patch, YARN-5956.12.patch, YARN-5956.13.patch, YARN-5956.14.patch,
YARN-5956.15.patch
>
>
> Some refactoring can be done in {{ClientRMService}}.
> - Remove redundant variable declaration
> - Fill in missing javadocs
> - Proper variable access modifier
> - Fix some typos in method name and exception messages



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message