hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sonia Garudi (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (YARN-6141) ppc64le on Linux doesn't trigger __linux get_executable codepath
Date Tue, 07 Feb 2017 12:13:41 GMT

    [ https://issues.apache.org/jira/browse/YARN-6141?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15855859#comment-15855859
] 

Sonia Garudi edited comment on YARN-6141 at 2/7/17 12:13 PM:
-------------------------------------------------------------

Thank you for the response. On checking, I found that __linux macro is not defined for C99
standard on ppc64le.

$ gcc -std=c99 -dM -E -xc /dev/null | grep linux
#define __linux__ 1
#define __gnu_linux__ 1

In the src/main/native/container-executor/impl/get_executable.c file, I changed the macro
from __linux  to __linux__  (since this macro is predefined on ppc64le for C99).
I got a successful build with this change. Attached a patch file with the same.


was (Author: sonia):
Thank you for the response. On checking, I found that __linux macro is not defined for C99
standard on ppc64le.

$ gcc -std=c99 -dM -E -xc /dev/null | grep linux
#define __linux__ 1
#define __gnu_linux__ 1

In the src/main/native/container-executor/impl/get_executable.c file, I changed the macro
from __linux to __linux__ (since this macro is predefined on ppc64le for C99).
I got a successful build with this change. Attached a patch file with the same.

> ppc64le on Linux doesn't trigger __linux get_executable codepath
> ----------------------------------------------------------------
>
>                 Key: YARN-6141
>                 URL: https://issues.apache.org/jira/browse/YARN-6141
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: nodemanager
>    Affects Versions: 3.0.0-alpha3
>         Environment: $ uname -a
> Linux f8eef0f055cf 3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:42:36 UTC 2015
ppc64le ppc64le ppc64le GNU/Linux
>            Reporter: Sonia Garudi
>              Labels: ppc64le
>
> On ppc64le architecture, the build fails in the 'Hadoop YARN NodeManager' project with
the below error:
> Cannot safely determine executable path with a relative HADOOP_CONF_DIR on this operating
system.
> [WARNING]  #error Cannot safely determine executable path with a relative HADOOP_CONF_DIR
on this operating system.
> [WARNING]   ^
> [WARNING] make[2]: *** [CMakeFiles/container.dir/main/native/container-executor/impl/get_executable.c.o]
Error 1
> [WARNING] make[2]: *** Waiting for unfinished jobs....
> [WARNING] make[1]: *** [CMakeFiles/container.dir/all] Error 2
> [WARNING] make: *** [all] Error 2
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> Cmake version used :
> $ /usr/bin/cmake --version
> cmake version 2.8.12.2



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message