hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Li Lu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-2355) MAX_APP_ATTEMPTS_ENV may no longer be a useful env var for a container
Date Tue, 24 Jan 2017 22:10:27 GMT

     [ https://issues.apache.org/jira/browse/YARN-2355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Li Lu updated YARN-2355:
------------------------
    Hadoop Flags: Incompatible change

> MAX_APP_ATTEMPTS_ENV may no longer be a useful env var for a container
> ----------------------------------------------------------------------
>
>                 Key: YARN-2355
>                 URL: https://issues.apache.org/jira/browse/YARN-2355
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Zhijie Shen
>            Assignee: Darrell Taylor
>              Labels: newbie
>             Fix For: 3.0.0-alpha1
>
>         Attachments: YARN-2355.001.patch
>
>
> After YARN-2074, YARN-614 and YARN-611, the application cannot judge whether it has the
chance to try based on MAX_APP_ATTEMPTS_ENV alone. We should be able to notify the application
of the up-to-date remaining retry quota.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message