hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira Ajisaka (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-6003) yarn-ui build failure caused by debug 2.4.0
Date Wed, 14 Dec 2016 17:21:58 GMT

     [ https://issues.apache.org/jira/browse/YARN-6003?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Akira Ajisaka updated YARN-6003:
--------------------------------
       Priority: Minor  (was: Critical)
    Description: 
The recent build failure: https://builds.apache.org/job/hadoop-qbt-trunk-java8-linux-x86/255/artifact/out/patch-compile-root.txt
{noformat}
/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/debug/debug.js:126
  debug.color = selectColor(namespae);
                            ^
ReferenceError: namespae is not defined
    at createDebug (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/debug/debug.js:126:29)
    at Object.<anonymous> (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/ember-cli/lib/models/project.js:16:43)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/ember-cli/lib/cli/index.js:4:21)
    at Module._compile (module.js:456:26)
{noformat}
build@2.4.0 is broken. https://github.com/visionmedia/debug/issues/347
Maybe we need to set the version to 2.4.1 explicitly.

  was:
The recent build failure: https://builds.apache.org/job/hadoop-qbt-trunk-java8-linux-x86/255/artifact/out/patch-compile-root.txt
{noformat}
/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/debug/debug.js:126
  debug.color = selectColor(namespae);
                            ^
ReferenceError: namespae is not defined
    at createDebug (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/debug/debug.js:126:29)
    at Object.<anonymous> (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/ember-cli/lib/models/project.js:16:43)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/ember-cli/lib/cli/index.js:4:21)
    at Module._compile (module.js:456:26)
{noformat}
build@2.4.0 is broken. https://github.com/visionmedia/debug/issues/347
Probably we need to set the version to 2.4.1 explicitly.


Now I compile yarn-ui locally and debug@2.4.1 is used. Maybe now this issue is not a problem.

> yarn-ui build failure caused by debug 2.4.0
> -------------------------------------------
>
>                 Key: YARN-6003
>                 URL: https://issues.apache.org/jira/browse/YARN-6003
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: build, yarn-ui-v2
>            Reporter: Akira Ajisaka
>            Priority: Minor
>
> The recent build failure: https://builds.apache.org/job/hadoop-qbt-trunk-java8-linux-x86/255/artifact/out/patch-compile-root.txt
> {noformat}
> /testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/debug/debug.js:126
>   debug.color = selectColor(namespae);
>                             ^
> ReferenceError: namespae is not defined
>     at createDebug (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/debug/debug.js:126:29)
>     at Object.<anonymous> (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/ember-cli/lib/models/project.js:16:43)
>     at Module._compile (module.js:456:26)
>     at Object.Module._extensions..js (module.js:474:10)
>     at Module.load (module.js:356:32)
>     at Function.Module._load (module.js:312:12)
>     at Module.require (module.js:364:17)
>     at require (module.js:380:17)
>     at Object.<anonymous> (/testptch/hadoop/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-ui/target/src/main/webapp/node_modules/ember-cli/lib/cli/index.js:4:21)
>     at Module._compile (module.js:456:26)
> {noformat}
> build@2.4.0 is broken. https://github.com/visionmedia/debug/issues/347
> Maybe we need to set the version to 2.4.1 explicitly.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message