hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Sasaki (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (YARN-5956) Refactor ClientRMService
Date Tue, 20 Dec 2016 12:58:58 GMT

    [ https://issues.apache.org/jira/browse/YARN-5956?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15764155#comment-15764155
] 

Kai Sasaki edited comment on YARN-5956 at 12/20/16 12:58 PM:
-------------------------------------------------------------

[~sunilg] Thanks for checking again.

{quote}
In checkAccess java doc comment, you mentioned uhe user
{quote}

Sorry that's just typo. I fixed.

{quote}
 Ideally we should be able to use verifyUserAccessForRMApp and getCallerUgi in all places
to avoid common code duplicated.
{quote}

Yes, I think so. But it's difficult to do here because error message would be changed if {{verifyUserAccessForRMApp}}
is used all places. 
Though we need to change the test code, it's beyond the refactoring. So keeping as it was
where the error message would be changed otherwise might be better.




was (Author: lewuathe):
[~sunilg] Thanks for checking again.

{quota}
In checkAccess java doc comment, you mentioned uhe user
{quota}

Sorry that's just typo. I fixed.

{quota}
 Ideally we should be able to use verifyUserAccessForRMApp and getCallerUgi in all places
to avoid common code duplicated.
{quota}

Yes, I think so. But it's difficult to do here because error message would be changed if {{verifyUserAccessForRMApp}}
is used all places. 
Though we need to change the test code, it's beyond the refactoring. So keeping as it was
where the error message would be changed otherwise might be better.



> Refactor ClientRMService
> ------------------------
>
>                 Key: YARN-5956
>                 URL: https://issues.apache.org/jira/browse/YARN-5956
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Kai Sasaki
>            Assignee: Kai Sasaki
>            Priority: Minor
>         Attachments: YARN-5956.01.patch, YARN-5956.02.patch, YARN-5956.03.patch, YARN-5956.04.patch,
YARN-5956.05.patch
>
>
> Some refactoring can be done in {{ClientRMService}}.
> - Remove redundant variable declaration
> - Fill in missing javadocs
> - Proper variable access modifier
> - Fix some typos in method name and exception messages



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message