hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Templeton (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5931) Document timeout interfaces CLI and REST APIs
Date Tue, 27 Dec 2016 14:45:58 GMT

    [ https://issues.apache.org/jira/browse/YARN-5931?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15780534#comment-15780534
] 

Daniel Templeton commented on YARN-5931:
----------------------------------------

A few more comments:

* "The possible combination of values" should just be "The possible values"
* "Timeout is configured and Application is RUNNING." should be "Timeout is configured and
application is RUNNING."
* "When you run a GET operation on this resource, you can obtain a collection of Application
Objects." should be "When you run a GET operation on this resource, a collection of Application
Objects is returned."  Yeah, it's passive voice, but this isn't a 9th grade book report. :)
* "When you run a GET operation on this resource, you can obtain a collection of Application
Timeout Objects." should be "When you run a GET operation on this resource, a collection of
Application Timeout Objects is returned."
* "Each timeout object represents timeout type" should be "Each timeout object is composed
of a timeout type"
* "Time at which application will get expired" should be "Time at which the application will
expire"
* In general, I disagree with the earlier comment that the "the"s should be dropped in the
docs.  It's fine in the javadocs, but the user docs should use "the application", i.e. they
shouldn't be in developer speak.
* With "Valid values are the members of the ApplicationTimeoutType enum: LIFETIME", I'd be
more explicit instead of using developer speak.  Something like, "Valid values are the members
of the ApplicationTimeoutType enum. LIFETIME is currently the only valid value."
* "Update timeout of an application from the time of request in seconds." is confusing.  How
about "Update application timeout (from the time of request) in seconds."

On a more meta level, 3s is fine with me.  1s would even be fine.

> Document timeout interfaces CLI and REST APIs
> ---------------------------------------------
>
>                 Key: YARN-5931
>                 URL: https://issues.apache.org/jira/browse/YARN-5931
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: scheduler
>            Reporter: Rohith Sharma K S
>            Assignee: Rohith Sharma K S
>         Attachments: ResourceManagerRest.html, YARN-5931.0.patch, YARN-5931.1.patch,
YARN-5931.2.patch, YarnCommands.html
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message