hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5756) Add state-machine implementation for queues
Date Fri, 16 Dec 2016 01:21:58 GMT

    [ https://issues.apache.org/jira/browse/YARN-5756?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15753079#comment-15753079

Wangda Tan commented on YARN-5756:

Thanks [~xgong],

Generally looks good, some minor comments:

1) AbstractCSQueue#initializeQueueState:
- initializeQueueState: is it better to rename current to previous?
- And can we make the initializeQueueState accept 3 parameters: previous/configured/parent,
with this we can do a more easier and comprehensive UT to make sure it won't break in the

2) Leaf(Parent)Queue#haveActiveApps can move to abstractCSQueue, or just completely remove
the method since we can use getNumApplications instead.

3) AbstractCSQueue#updateQueueState, writeLock is not necessary for volatile. {{queueStateWriteLock}}
can be directly removed.

4) QueueStateManager is not used by anybody now? Is it better to move to a separated patch?
Which JIRA you plan to use it?

> Add state-machine implementation for queues
> -------------------------------------------
>                 Key: YARN-5756
>                 URL: https://issues.apache.org/jira/browse/YARN-5756
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Xuan Gong
>            Assignee: Xuan Gong
>         Attachments: YARN-5756.1.patch, YARN-5756.2.patch, YARN-5756.3.patch, YARN-5756.4.patch,
YARN-5756.5.patch, YARN-5756.6.patch, YARN-5756.6.patch

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message